Server-side Request Forgery (SSRF)

Affecting systeminformation package, versions <5.3.4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

systeminformation is a simple system and OS information library.

Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF) via the sanitizeShellString function due to not sanitising @ properly.

PoC

const si = require('systeminformation');
si.inetChecksite("https://effectrenan.com@google.com").then(a => { console.log(a) });

Remediation

Upgrade systeminformation to version 5.3.4 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:P
Credit
huntr-helper
CWE
CWE-918
Snyk ID
SNYK-JS-SYSTEMINFORMATION-1078290
Disclosed
22 Feb, 2021
Published
04 Mar, 2021