Command Injection

Affecting systeminformation package, versions <4.27.11

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

systeminformation is a simple system and OS information library.

Affected versions of this package are vulnerable to Command Injection. This package is vulnerable to Command Injection. The attacker can concatenate curl's parameters to overwrite Javascript files and then execute any OS commands.

Remediation

Upgrade systeminformation to version 4.27.11 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:R
Credit
EffectRenan
CVE
CVE-2020-7752
CWE
CWE-78
Snyk ID
SNYK-JS-SYSTEMINFORMATION-1021909
Disclosed
25 Oct, 2020
Published
26 Oct, 2020