Insufficient Validation

Affecting redbird package, versions <0.9.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

redbird is a complete library to build dynamic reverse proxies with the speed and robustness of http-proxy.

Affected versions of this package are vulnerable to Insufficient Validation. There is no option in lib/proxy.js which would allow for disabling TLS1.0 connections, which are considered to be vulnerable and deprecated.

Remediation

Upgrade redbird to version 0.9.1 or higher.

References

CVSS Score

4.2
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
Credit
James Thomas
CWE
CWE-20
Snyk ID
SNYK-JS-REDBIRD-174455
Disclosed
17 Apr, 2019
Published
18 Apr, 2019