Out-of-bounds Read

Affecting flipper-folly package, versions <2.2.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Flipper-Folly is a library of C++14 components designed with practicality and efficiency in mind. Folly contains a variety of core library components used extensively at Facebook.

Affected versions of this package are vulnerable to Out-of-bounds Read. Improper handling of close_notify alerts can result in an out-of-bounds read in AsyncSSLSocket.

Remediation

Upgrade Flipper-Folly to version 2.2.0 or higher.

References

CVSS Score

9.8
critical severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2019-11934
CWE
CWE-125
Snyk ID
SNYK-COCOAPODS-FLIPPERFOLLY-1039751
Disclosed
12 Apr, 2019
Published
12 Nov, 2020