Heap-based Buffer Overflow

Affecting ffmpeg-up-to-date package, versions >=0.0.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

FFmpeg-up-to-date is a FFmpeg static libraries compiled for iOS

Affected versions of this package are vulnerable to Heap-based Buffer Overflow. cbs_jpeg_split_fragment in libavcodec/cbs_jpeg.c has a heap-based buffer overflow during JPEG_MARKER_SOS handling because of a missing length check.

Remediation

There is no fixed version for FFmpeg-up-to-date.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:U/RC:C
Credit
Unknown
CVE
CVE-2020-12284
CWE
CWE-122
Snyk ID
SNYK-COCOAPODS-FFMPEGUPTODATE-567842
Disclosed
28 Apr, 2020
Published
28 Apr, 2020