Buffer Overflow

Affecting ffmpeg-up-to-date package, versions >=0.0.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

FFmpeg-up-to-date is a FFmpeg static libraries compiled for iOS

Affected versions of this package are vulnerable to Buffer Overflow via a Buffer Overflow in libavcodec.

Remediation

A fix was pushed into the master branch but not yet published.

References

CVSS Score

8.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2021-30123
CWE
CWE-120
Snyk ID
SNYK-COCOAPODS-FFMPEGUPTODATE-1244088
Disclosed
08 Apr, 2021
Published
08 Apr, 2021