Use After Free

Affecting electron package, versions <6.1.10 || >=7.0.0 <7.2.2 || >=8.0.0-beta.1 <8.2.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Use After Free. The rendering_orphan_handlers_ and deletable_orphan_handlers_ handlers can hold references to the context after BaseAudioContext is destroyed.

Remediation

Upgrade electron to version 6.1.10, 7.2.2, 8.2.1 or higher.

References

CVSS Score

6.8
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Credit
Unknown
CWE
CWE-416
Snyk ID
SNYK-JS-ELECTRON-565709
Disclosed
08 Apr, 2020
Published
15 Apr, 2020