Improper Input Validation

Affecting electron package, versions <10.4.2 || >=11.0.0 <11.4.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Improper Input Validation. It allowed a remote attacker to leak cross-origin data via a crafted HTML page.

Remediation

Upgrade electron to version 10.4.2, 11.4.1 or higher.

References

CVSS Score

8.6
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L/E:U/RL:O/RC:R
Credit
Unknown
CVE
CVE-2021-21175
CWE
CWE-20
Snyk ID
SNYK-JS-ELECTRON-1086695
Disclosed
18 Mar, 2021
Published
25 Mar, 2021