@reldb/auth@0.2.1

Vulnerabilities

1 via 2 paths

Dependencies

836

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

high severity

Command Injection

  • Vulnerable module: lodash.template
  • Introduced through: @reldb/run@0.9.1

Detailed paths

  • Introduced through: @reldb/auth@0.2.1 @reldb/run@0.9.1 lerna@4.0.0 @lerna/version@4.0.0 @lerna/conventional-commits@4.0.0 lodash.template@4.5.0
  • Introduced through: @reldb/auth@0.2.1 @reldb/run@0.9.1 lerna@4.0.0 @lerna/publish@4.0.0 @lerna/version@4.0.0 @lerna/conventional-commits@4.0.0 lodash.template@4.5.0

Overview

lodash.template is a The Lodash method _.template exported as a Node.js module.

Affected versions of this package are vulnerable to Command Injection via template.

PoC

var _ = require('lodash');

_.template('', { variable: '){console.log(process.env)}; with(obj' })()

Remediation

There is no fixed version for lodash.template.

References